IPV6

বারোটায় অফিস আসি, দু’টায় টিফিন
তিনটেয় যদি দেখি সিগনাল গ্রীন
চটিটা গলিয়ে পায়, নিপাট নির্দ্বিধায়
চেয়ারটা কোনমতে ছাড়ি
কোন কথা না বাড়িয়ে, ধীরে ধীরে পা বাড়িয়ে
চারটেয় চলে আসি বাড়ি
আমি সরকারি কর্মচারী, আমি সরকারি কর্মচারী।
দিন পাল্টাচ্ছে, আগে সরকারী চাকরি কথা শুনলেই কি রকম অনিহা প্রকাশ করতাম । কারণ একটাই বেতন কম। এত অল্প টাকা দিয়ে জীবন যাপন করা কষ্ট কর । কিন্তু কিছু দিন আগে শুনলাম সরকারি চাকরিজিবিদের নতুন বেতন স্কেল করা হয়েছে। কারণ এখন আর এত অল্প টাকা দিয়ে চলচ্ছে না । তাই বেতন বাড়ানো হচ্ছে। নেটওয়ার্কিং এর ক্ষেত্রেও IPv4 এর এড্রেস দিয়ে চলে যাচ্ছিল কিন্তু যেভাবে ইন্টারনেট ব্যবহারকারীর সংখ্যা বৃদ্ধি পাচ্ছে এই অল্প এড্রেস দিয়ে আর হচ্ছে না তাই IPv6 এর উদ্ভব।

চলেন তাহলে IPv6 নিয়ে কিছুটা জানার চেষ্টা  করি

IPv6 এর বেসিক ধারণা

IPv6 হলো একটি প্রটোকল। IPv6 এর এড্রেস হলো ১২৮ বিটের । ইন্টারনেটে নতুন পরিচয় হিসেবে চালু হলো ইন্টারনেট প্রটোকল ভার্সন ৬ (IPv6) ইন্টারনেট সোসাইটির বরাতে এক খবরে বিবিসি জানিয়েছে, ট্রিলিয়নেরও অধিক ইন্টারনেট ব্যবহারকারীর নিজস্ব আইপি ঠিকানা হিসেবে পরিচিতি দিতেই আইপিভি ৬ চালু হয়েছে।

 কেন IPv6 প্রয়োজন?

আমরা সবাই জানি IPv4 হলো ৩২ বিটের। সুতরাং এর এড্রেসের সংখ্যা হলো ২^৩২ = ৪২৯৪৯৬৭২৯৬ টি। কিন্তু ইন্টারনেট ব্যবহারের সংখ্যা যেভাবে  দিন দিন বৃদ্ধি পাচ্ছে, এই এড্রেসগুলো দ্রুতই শেষ হয়ে যাবে। তাই এই সীমাবদ্ধতা দূর করার জন্য IPv6  এর সংস্করন।

IPv6  এর প্রকারভেদ

১) ইউনিকাস্ট (Unicast)

ইউনিকাস্ট হলো সিঙ্গেল ইন্টারফেস আইডেন্টিফায়ার । অথার্ৎ ওয়ান টু ওয়ান কমিউনিকেশন। যেমন- আপনি একটি ফাই ল সার্ভার এর কথা ভাবতে পারেন। আপনার ফাইল ষার্ভার হলো সেন্ডার আর আপনার কম্পিউটার হলো রিসিভার।

Unicast

2) মাল্টিকাস্ট (Multicast)  

IPv6  এ মাল্টিকাস্ট এড্রেস হলো  FF00::/8. IPv6 এর এই মাল্টিকাস্টিং এড্রেসকে   IPv4 এর Broadcast  এর সাথে তুলনা করা যায়। অনেকগুলি হোস্টে নিকট কোনো মেসেজ পাঠাতে IPv6 এই মাল্টিকাস্ট ব্যবহার করে। লক্ষ্যণীয় যে  IPv6 এ Broadcast নেই, ফলে মাল্টিকাস্ট অনেক গুরুত্বপূর্ন।

Multicast

মাল্টিকাস্ট হলো গ্রুপ অফ নোডের আইডেন্টিফায়ার । অথার্ৎ ওয়ান টু মেনি। এই ধরনের কমিউনিকেশনে সেন্ডার   গ্রুপ অফ হোস্টের সাথে কমিউনিকেট করতে পারে।

 

৩) এনিকাস্ট (Anycast)

এনিকাস্ট হলো সেট অফ ইন্টারফেসের আইডেন্টিফায়ার । যদি একই ধরনের সার্ভার থাকে আহলে একটি আইপি  একাধিক সার্ভারের সাথে কমিউনিকেট করতে পারে। ইহা কমিউকেট করে থাকে ডিসটেন্স এর উপরে।

Anycast

 

 

IPv6 এড্রেস রিপ্রেজেন্টশন:

অনেকেই  IPv6 এর এড্রেস দেখে মনে করে এত বড় আমরা মনে রাখা তো কঠিন কাজ। কিন্তু এই কঠিন কাজই আমরা খুব সহজেই মনে রাখতে পারি । মনে করি আমাদের একটি  IPv6 এোড্রস হলো

2001:0BA7:0002:008D:0000:0000:42A6:52F5

এই এড্রেসটি আমরা খুব সহজেই ০গুলোকে বাদ দিয়ে লিখতে পারি

2001:BA7 :2:8D:0:0:42A6:51F5

ফাইনালে আমরা এই এড্রেসটাকে এভাবে লিখতে পারি

2001:BA7:2:8D::42A6:51F5

 

চলুন এবার একটি গুরুত্বর্পুন বিষয় নিয়ে আলোচনা করি। আমাদের IPv4  এর মধ্যে দিয়ে মধ্যে দিয়ে কিভাবে IPv6  এর টানেলিং করা যায়, সেই বিষয়টি দেখি…..

tunnel

R1 router Interface configuration command line:

Router>en

Router#configure ter

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 192.168.20.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface fastEthernet 0/1

R1(config-if)#ip address 192.168.30.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R1(config-if)#ipv6 address FEC0::1:1/120

R1(config-if)#no sh

R1(config-if)#no shutdown

R1(config-if)#

 

R2 Router interface configuration command line

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R2

R2(config)#exit

R2#

%SYS-5-CONFIG_I: Configured from console by console

R2#wr

Building configuration…

 

Routing

EIGRP configure in R1 router

R1#conf

R1#configure ter

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#rou

R1(config)#router ei

R1(config)#router eigrp 1

R1(config-router)#net

R1(config-router)#network 192.168.30.0

R1(config-router)#net

R1(config-router)#network 192.168.20.0

R1(config-router)#

R1#

 

EIGRP configure in R2 router

R2#en

R2#conf

R2#configure ter

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#ro

R2(config)#router ei

R2(config)#router eigrp 1

R2(config-router)#net

R2(config-router)#network 192.168.20.0

R2(config-router)#

%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.20.1 (FastEthernet0/0) is up: new adjacency

net

R2(config-router)#network 192.168.40.0

R2(config-router)#exit

R2(config)#exit

R2#

%SYS-5-CONFIG_I: Configured from console by console

 

R2#wr

Building configuration…

[OK]

R2#

 

R1 to R2 router tunnel configuration command

 

R1router command line

R1#

R1#conf

R1#configure ter

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#inter

R1(config)#interface tu

R1(config)#interface tunnel

% Incomplete command.

R1(config)#interface tunnel 1

R1(config-if)#

%LINK-5-CHANGED: Interface Tunnel1, changed state to up

R1(config-if)#

R1(config-if)#ipv

R1(config-if)#ipv6 en

R1(config-if)#ipv6 enable

R1(config-if)#tun

R1(config-if)#tunnel mo

R1(config-if)#tunnel mode ip

R1(config-if)#tunnel mode ipv6ip

R1(config-if)#tun

R1(config-if)#tunnel so

R1(config-if)#tunnel source inter

R1(config-if)#tunnel source fas

R1(config-if)#tunnel source fastEthernet 0/0

R1(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up

R1(config-if)#tun

R1(config-if)#tunnel des

R1(config-if)#tunnel destination 192.168.20.2

R1(config-if)#ipv

R1(config-if)#ipv6 add

R1(config-if)#ipv6 address FEC0::14:2/120

R1(config-if)#exit

R1(config)#exit

R1#

%SYS-5-CONFIG_I: Configured from console by console

R1#wr

Building configuration…

[OK]

R1#

 

R2 router command line

R2>en

R2#con

R2#conf

R2#configure te

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#inte

R2(config)#interface tu

R2(config)#interface tunnel 1

R2(config-if)#

%LINK-5-CHANGED: Interface Tunnel1, changed state to up

R2(config-if)#ipv

R2(config-if)#ipv6 en

R2(config-if)#ipv6 enable

R2(config-if)#tun

R2(config-if)#tunnel mo

R2(config-if)#tunnel mode ipv

R2(config-if)#tunnel mode ipv6ip

R2(config-if)#tun

R2(config-if)#tunnel so

R2(config-if)#tunnel source fas

R2(config-if)#tunnel source fastEthernet 0/0

R2(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up

R2(config-if)#tu

R2(config-if)#tunnel de

R2(config-if)#tunnel destination 192.168.20.1

R2(config-if)#ipv

R2(config-if)#ipv6 add

R2(config-if)#ipv6 address FEC0::14:1/120

R2(config-if)#no sh

R2(config-if)#no shutdown

R2(config-if)#

 

Routing enable in R1 for IPv6 

R1#conf

R1#configure ter

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ipv

R1(config)#ipv6 uni

R1(config)#ipv6 unicast-routing

R1(config)#inter

R1(config)#interface fast

R1(config)#interface fastEthernet 0/1

R1(config-if)#ipv6 eigrp 5

R1(config-if)#exit

R1(config)#inter

R1(config)#interface tun

R1(config)#interface tunnel 1

R1(config-if)#ipv6 eigrp 5

R1(config-if)#ipv

R1(config-if)#ipv6 router

R1(config-if)#ipv6 router ei

R1(config-if)#ipv6 router eigrp 5

R1(config-rtr)#no sh

R1(config-rtr)#no shutdown

R1(config-rtr)#

 

Routing enable in R2 for IPv6 

R2#conf

R2#configure te

R2(config)#ipv6 unicast-routing

R2(config)#interface fast

R2(config)#interface fastEthernet 0/1

R2(config-if)#ipv

R2(config-if)#ipv6 ei

R2(config-if)#ipv6 eigrp 5

R2(config-if)#exit

R2(config)#inte

R2(config)#interface tun

R2(config)#interface tunnel 1

R2(config-if)#ipv

R2(config-if)#ipv6 ei

R2(config-if)#ipv6 eigrp 5

R2(config-if)#ipv6 router eigrp 5

R2(config-rtr)#no shutdown

R2(config-rtr)#

IPv4  এর মধ্যে দিয়ে মধ্যে দিয়ে কিভাবে IPv6  এর টানেলিং  শেষ। সুতরাং আজকের মতো এখানেই শেষ করছি। সবার সুস্বাস্থ্য কামনা করে এখানেই শেষ করছি।

 

Leave a Reply

Your email address will not be published. Required fields are marked *

*

CAPTCHA * Time limit is exhausted. Please reload the CAPTCHA.